Back to overview
Resolved

AWS CloudFront VPC Origins outage affecting selected Myver services

Jul 16, 2026 at 7:55am UTC
Affected services
Merchant Portal
Find My Receipt
Receipt Presentation

Resolved
Jul 16, 2026 at 12:22pm UTC

The issue has been resolved, and all affected Myver services are operating normally.

AWS has confirmed that the underlying CloudFront VPC Origins incident has been fully mitigated and resolved. We have verified normal operation of the affected services and are closing this incident.

We apologize for any inconvenience caused and appreciate your patience while the issue was being resolved.

AWS status: https://health.aws.amazon.com/health/status

Updated
Jul 16, 2026 at 11:20am UTC

We are seeing normal service levels restored, and the affected Myver services are currently operating as expected. We will continue to closely monitor the situation before declaring the incident fully resolved.

AWS has confirmed they have identified a mitigation strategy for the underlying CloudFront VPC Origins issue and are reporting initial signs of recovery while they continue working toward full recovery.

AWS status: https://health.aws.amazon.com/health/status

Updated
Jul 16, 2026 at 10:21am UTC

We have confirmed that the impact is caused by an ongoing AWS CloudFront incident affecting VPC Origins connectivity. AWS has identified the likely root cause and continues to work on restoring service.

At this time, there is no change in the impact to affected Myver services, and we continue to monitor the incident closely.

AWS status: https://health.aws.amazon.com/health/status

Created
Jul 16, 2026 at 7:55am UTC

We are currently investigating an issue affecting the QR Receipt, Merchant Portal, and Self-service Receipt Finder services.

Our investigation indicates that the issue is caused by an ongoing AWS CloudFront incident affecting customers using VPC Origins. At this time, there is no action required from customers, and we are actively monitoring the situation while AWS works to restore normal service.

You can follow AWS’s official service status and updates here: https://health.aws.amazon.com/health/status

We will provide further updates as soon as more information becomes available or the issue has been resolved.